Основы WorldEd для начинающих

Для работы вам понадобятся следующий софт:

  • Arcanum World Editor v.1.0.6.9. - непосредственно сам редактор карт. Он поставляется вместе с игрой, но различается в зависимости от версии игры. В данном мануале рассматривается редактор версии 1.0.6.9. Именно эта версия редактора входит в состав GrandFix, но её можно скачать и отдельно.

  • DiAreA - самый лучший редактор диалогов Arcanum.

  • ScrMaker - редактор скриптов. Поставляется вместе с игрой.

  • Текстовый редактор (вроде стандартного Блокнота) - для правки mes-файлов.

Модули хранятся в папке modules, находящейся в папке игры. Каждый модуль находится в отдельной папке с его названием и dat-файле.

Внимание: Не играйте в Арканум или любые другие модули, в то время как WorldEd открыт. WorldEd попытается изменять файлы, которые могут использоваться игрой.

Intro

Первое, что вы увидите когда WorldEd загрузится - это окно "Open Module" где можно выбрать существующие модули (в папке /Arcanum/modules) или создать свой. Для этого введите имя несуществующего модуля в текстовом поле "Enter Module Name", и он будет создан.

Если вы хотите редактировать сам Арканум (т.е. модуль Arcanum), то нужно сначала распаковать файл Arcanum.dat (из папки modules) в находящуюся там же папку Arcanum. Для распаковки можно использовать DatBuilder или другие распаковщики.

Если создаётся отдельный модуль (отдельная игра на движке Арканума), то можно добавить поддержку сетевой игры. Примером такого модуля служит Vormantown. Главное отличие сетевого модуля - ВСЕ локации ДОЛЖНЫ БЫТЬ на одной карте. При создании сетевого модуля надо поставить галочку "Allow Multiplayer".

При открытии модуля WorldEd всегда создаёт новую карту Untitled с зелёным полем и, на мой взгляд, слишком уж настойчиво предлагает её сохранить, хотя сохранять там толком нечего. Так что всегда отказывайтесь.

Чтобы создать новую карту, выберите "File" -> "New...". Появится окошко с основными параметрами новой карты:

Base terrain type - это тип основного ландшафта. Например, если вы выбрали "snowy plains", то вашей картой будет снежный ландшафт. Конечно, этот выбор не запрещает вам изменять отдельные клетки ландшафта. Если хотите получить совершенно пустую карту, то выбирайте "water".

Sectors - это размер карты в секторах. Помните, что если вы делаете сетевой модуль, то эта карта будет единственной в модуле (кроме карты ShopMap - стартовый магазин) и потому она должна быть достаточно большой. Тройка рекомендует для сетевых модулей карту 100 x 100.

Точка Старта

Точка Старта - это место где игрок начнет своё приключение. В Аркануме это место падения Зефира, а в вашем модуле выбирайте сами, где лучше начать играть. Чтобы установить точку старта надо прописать её в файл MapList.mes, который находится в каталоге rules вашего модуля. Открыв этот файл, вы увидите в конце такие строки:

{5000}{ShopMap, 31, 29, Type: SHOPPING_MAP}
{5001}{start, 2048, 2048, Type: START_MAP, WorldMap: 0}

Первая строка указывает карту первой покупки вещей. НЕ ИЗМЕНЯЙТЕ эту строку.

Вторая строка, указывает стартовую карту и координаты точки старта. Замените название start на название вашей карты (если вы не назвали её start изначально). Теперь замените координаты после названия карты. Их вы можете узнать, наведя мышь на предполагаемую точку старта и увидеть их в ячейках, расположенных прямо над миникартой в левой части экрана.

Не забывайте прописывать в файл MapList.mes новые карты в этом модуле, так как это необходимо для работы точек и скриптов перехода с одной карты на другую.

Пример строки, прописывающей новую карту:

{5002}{new, 2048, 2048, WorldMap: 0}

Автор: gamer_777

arcanumclub.com


Интерфейс

File

  • New - создает новую карту в текущем модуле.

  • O pen... - открывает существующую карту в текущем модуле.

  • Open Module... - открывает существующий модуль или если вы введете новое имя модуля, редактор создаст новый.

  • Compress module... - запаковывает весь модуль в dat-файл.

  • Save (and Unlock) - сохраняет изменения на карте.

  • Save Map as... (and Unlock) - сохраняет вашу карту с новым именем. Эта новая карта и старая будут в вашем модуле.

  • Revert - отменяет все изменения, которые вы сделали начиная с последнего сохранения карты.

  • Exit - выход из WorldEd.

View

  • Zoom In

  • Zoom Out - эти две опции увеличивают и уменьшают масштаб изображения. (горячие клавиши "+" "-"). Примечание: они работают ТОЛЬКО в режиме "Top-down" (вид сверху).

  • Scrolling - настройка скорости прокрутки экрана. Если эта опция выбрана по умолчанию, то скорость прокрутки будет самой быстрой.

  • Objects - в этом подменю можно скрыть или показать большинство объектов, которые существуют на карте, в окне редактирования.

  • Game Window - красный прямоугольник, который показывает, что игрок будет видеть во время игры. Размер прямоугольника - 800x400.

  • Center Crosshair - показывает центр экрана.

  • Sectors - показывает границы секторов в режиме "Top-down"

  • Ambient Lighting - Снятие галочки этой опции убирает стандартную схему освещения вашей карты. Имейте в виду, что это не имеет никакого отношения к освещению в игре. Это только для рассмотрения целей в WorldEd.

  • Ambient Colors - все эти опции регулируют вид освещения. Они НЕ влияют на освещение в игре и не сохраняются. Это сделано просто для того, чтобы можно было посмотреть как будет всё выглядеть при разном освещении прямо в редакторе.

Indoor - управляет уровнем освещения во внутренних областях (т.е. в зданиях). Очень полезно установить здесь белый цвет, таким образом ярко осветив все тёмные помещения.
Outdoor - управляет уровнем освещения во внешних областях.
Scheme - позволяет выбирать между различными схемами освещения, доступными в вашем модуле. По умолчанию, у вас есть две схемы, но вы можете создавать ваши собственные. Когда они созданы, они будут автоматически появляться в этом диалоге.

Tools

  • Align Inventory - поиск и исправление сбойных предметов.

  • Respawn Inventory - перезагрузка инвентаря у всех NPC.

  • Purge Destroyed Objects - поиск и удаление объектов, которые были разрушены, но не удалены.

  • Relevel - перезагрузка схем развития для всех NPC на карте.

  • Check Waypoints - проверка всех точек пути (waypoints).

  • Export terrain bitmap... - сохраняет ланшафт карты в виде файла BMP.

  • Generate town maps - генерирует городские карты (TownMaps) для всех карт в данном модуле. (см. раздел "Секторы карты" в данном мануале).

  • Remove sector light schemes - удаление всех схем освещения, сделанных вручную.

  • Count duplicates - поиск дублированных объектов между всеми картами данного модуля.

  • Check for bad art - проверка файлов art на соответствие art id в объектах.

  • Find Next Useable Scenery Object - поиск объектов пейзажа к которым привязаны скрипты с помощью метки "Use". Очень полезно на больших картах.

  • Find previus Useable Scenery Object - то же что и выше, за исключением того, что поиск идёт в обратном направлении.

  • Find Next Blocked Container Object - поиск блокированных контейнеров. Контейнеры не могут быть открыты или использоваться, если они находятся на блокированном тайле(клетке). Тайлы могут быть блокированы или вручную или другим объектом, находящимся на одном с контейнером тайле.

  • Find Previous Blocked Container Object - то же что и выше, за исключением того, что поиск идёт в обратном направлении.

  • Adjust critter wanders - этот инструмент влияет на блуждающих существ на данной карте. Блуждающее существо двигается в случайном порядке там, где вы его поместили. Блуждание каждого существа может быть настроено с помощью флагов (см. раздел "Флаги").

Теперь переходим к боковой панели редактора:

1 Пять закладок с инструментами. Их мы рассмотрим в следующих разделах данного мануала.

2 Выбор типа объекта.

3 Выбор и редактирование объекта.

4 Режимы редактирования карты:

  • Isometric - стандартный режим.
  • Top-down - Вид сверху. Позволяет масштабировать карту и строить дома.
  • Edit terrain... - редактор ландшафта. Позволяет быстро создавать леса горы и т.д.

5 Координаты (в тайлах).

6 Миникарта.

7 Координаты (в секторах).

Чтобы перемещаться по карте, включите NumLock и используйте цифры на NumPad'e. Для быстрого перемещения введите координаты над миникартой и нажмите кнопку "Set". Или можно просто щёлкнуть на миникарте.


Environment

Курсор - это переключатель в режим выбора объекта. Вы можете перемещать и копировать любые объекты (для копирования удерживайте нажатой кнопку Ctrl).
Для удобства эта кнопка продублирована во всех закладках.

Внимание! При перемещении любых существ не забывайте обозначить для них новую дневную и ночную точки. Для этого после перемещения щёлкните правой кнопкой мыши на существе и выберите "Day Stand", а затем также "Night Stand". (см. раздел "NPC").

Если этого не сделать - существо в игре будет находиться не на том месте, куда вы его переместили, а там где вы его создали. Причём это будет заметно только в игре, но не в редакторе!

Удалить - это переключатель в режим удаления. Просто нажмите эту кнопку и затем щёлкните на том, что вы хотите удалить. Для удобства эта кнопка продублирована во всех закладках.
Примечание: чтобы удалять стены - удерживайте при этом нажатой кнопку Ctrl.

Тайл - это клетка ландшафта. Выбрав этот инструмент, нажмите кнопку "Select". В появившемся окне можно выбрать любую поверхность: траву, снег, воду и т.д. Дважды щёлкните на нужном типе и вы сможете рисовать выбранную поверхность.

Некоторые тайлы предназначены для внешнего освещения, а другие - для внутреннего. Поместив их рядом, вы заметите, что внутренние тайлы заметно темнее внешних. Это происходит потому, что они используют разные схемы освещения. Также внутренние и внешние тайлы не делают плавных переходов между собой.

Примечание: если вы хотите рисовать поверхность по одному тайлу, то удерживайте нажатой кнопку Ctrl.

Элементы пейзажа - это деревья, мебель, картины на стенах, мелкие предметы, уличные фонари и многое другое.

Контейнеры - это сундуки, бочки, ящики и другие объекты, которые могут содержать множество предметов. Контейнеры могут быть пустыми, содержать предметы и принадлежать NPC. По умолчанию, все контейнеры имеют "исходный инвентарь" (список предметов).

Чтобы создать контейнер с вашими предметами, выберите в выпадающем списке прототип "Пустой ящик". Этот прототип не имеет инвентаря по умолчанию. Создайте рядом с контейнером нужные вам предметы и перетаскивайте мышью предметы на контейнер.

Чтобы удалить содержимое контейнера, щёлкните на нём правой кнопкой мыши и выберите "Poop". В результате, весь инвентарь окажется на земле. Вам, возможно, придётся переместить контейнер, чтобы увидеть предметы под ним.

Вы можете сделать контейнер с любым внешним видом (дерево, элемент пейзажа и т.д.). Для этого создайте простой контейнер, щёлкните его правой кнопкой мыши и выберите "Edit". В появившемся окне щёлкните значок изображения (отмечен красным кружком на скриншоте ниже).

В появившемся окне выбора изображений надо щёлкнуть пустой квадрат "unknown" в верхнем левом углу (отмечен красным квадратом на скриншоте ниже).

В результате, окно редактирования будет выглядеть так:

Не закрывая окно, щёлкните синий квадрат с надписью "Empty", чтобы вызвать окно выбора группы изображений:

Выпадающий список "List" оставьте как есть, а вот "Sublist" это и есть выбор группы изображений. Выберите группу и щёлкните "OK". Перед вами появится окно с выбранной группой изображений, щёлкните нужное и всё.

Примечание: подобные трюки можно проделать не только с контейнерами. Например, можно превратить NPC в дерево.

Ловушки - находятся на земле и затрагивают любого, кто на них наступит. Чтобы разместить ловушку, выберите этот инструмент и щёлкните левой кнопкой мыши там, где вы хотите поместить ловушку. Вы также можете выбрать тип ловушки (доступно 7 типов) с помощью кнопки "Edit".

Ловушки стреляющие стрелами требуют для работы дополнительную ловушку - ловушку-источник (trap-source), который определяет откуда полетит стрела. Ловушка-источник невидима во время игры, вы можете поместить её где угодно и игрок будет видеть только летящие стрелы.

Примечание: расстояние между ловушкой и ловушкой-источником не должно быть более 6 тайлов. При этом будет использоваться ближайшая ловушка-источник.

Любая ловушка может быть отредактирована. Для этого щёлкните правой кнопкой мыши на ловушке, выберите "Edit" и нажмите кнопку "Scripts...". На скриншоте ниже отмечены четыре основных параметра ловушки.

Counter 0 - минимальный урон от ловушки.
Counter 1 - максимальный урон.
Counter 2 - номер ловушки-источника (trap-source).
Counter 3 - номер заклинания, которое будет накладываться на жертву. Это заклинание будет дополнительным - т.е. не заменит стандартный эффект ловушки.

Фасады - это группы тайлов, которые формируют изображение. Это плоское двухмерное изображение может создавать иллюзию большого замка или бездонной пропасти. Выбрав этот инструмент, вы увидите чуть ниже номер фасада. Кнопками "previous" и "next" можно выбирать фасад. Всего в Аркануме есть 372 фасада. Выбрав номер фасада, щелкните левой кнопкой там где хотите поместить фасад.

Если при этом удерживать левую кнопку мыши нажатой, то можно двигать фасад по карте перед его установкой. Таким способом можно точно подгонять фасады один к одному (например, фрагменты замка).

Как и все остальные объекты, фасад удаляется инструментом "Удалить". Помните, фасад - это группа тайлов. Некоторые фасады - наружные тайлы, а некоторые внутренние, так что освещение влияет на них по-разному. Кроме того на них можно поместить объект пейзажа.

Свет - эта кнопка устанавливает источники света. Нажав на кнопку "Select" можно выбрать тип освещения. Кнопка "Edit" определяет цвет освещения. Следует разумно размещать источники света, так-как большое их кол-во способно привести к тормозам в игре. Если вы хотите осветить большую область - лучше будет вместо них использовать Схему Освещения (см. раздел "Карты").

Не удивляйтесь, если вдруг не увидите созданный источник света. Это может произойти из-за слишком яркого окружающего освещения, на фоне которого источник света не виден. Чтобы видеть все источники света, выберите "View" -> "Ambient Colors" -> "Scheme". В появившимся окошке установите нужное время (например, 2 часа). Теперь в вашем мире наступит ночь и все источники света будут видны.

Примечание: Вы можете превратить свет, наоборот, в тень. Для этого щёлкните правой кнопкой мыши на источнике света и выберите "Edit". В появившемся окне отметьте галочкой "dark (shadow)".


Items

Курсор - это переключатель в режим выбора. Вы можете перемещать и копировать любые объекты (для копирования удерживайте нажатой кнопку Ctrl).
Для удобства эта кнопка продублирована во всех закладках.

Внимание! При перемещении любых существ не забывайте обозначить для них новую дневную и ночную точки. Для этого после перемещения щёлкните правой кнопкой мыши на существе и выберите "Day Stand", а затем также "Night Stand". (см. раздел "NPC").

Если этого не сделать - существо в игре будет находиться не на том месте, куда вы его переместили, а там где вы его создали. Причём это будет заметно только в игре, но не в редакторе!

Удалить - это переключатель в режим удаления. Просто нажмите эту кнопку и затем щёлкните на том, что вы хотите удалить. Для удобства эта кнопка продублирована во всех закладках.
Примечание: чтобы удалять стены - удерживайте при этом нажатой кнопку Ctrl.

Общие предметы - это квестовые и используемые в техно-схемах предметы.

Оружие - всего есть 11 типов оружия: мечи, двуручные мечи, луки, пистолеты и т.д. Как только вы выбрали тип в выпадающем списке, нажмите "Select", чтобы выбрать нужное вам оружие. Некоторое оружие в игре содержит заклинания, которые могут использоваться когда оружие в руке, например Посох Лечения. Некоторое оружие для использования требует боеприпасы (стрелы, патроны, заряды или топливо).

Чтобы создать ваше собственное оружие, поместите подобное оружие на карту, щёлкните на нём правой кнопкой мыши и выберите "Edit".

Броня. Так же как и оружие, броня делится на много типов и может быть отредактирована.

Еда - здесь вы найдете не только еду, но ещё различные зелья и предметы, используемые для их приготовления (табак, корень гинка и т.д.).

Письменные объекты - это пять различных типов письменных объектов, которые вы можете выбрать в выпадающем меню: книги, газеты, записки, технологические схемы, телеграммы.

Письменные объекты подобны другим объектам в игре, за исключением нескольких параметров внизу их окна редактирования.
"Written Type" позволит вам менять тип уже созданного письменного объекта.
"Start Line" определяет какая строка с текстом в файле mes будет отображаться.

Свитки - это объекты содержащие заклинания. Кнопка "Select" позволяет выбрать тип свитка.

Боеприпасы делятся на четыре вида: стрелы, патроны, заряды, и топливо. Различное оружие в игре требует различных типов боеприпасов. Чтобы выбрать кол-во боеприпасов, щёлкните правой кнопкой мыши на созданных боеприпасах и выберите "Edit". В появившемся меню введите нужное цифру в поле "quantity".

Монеты. Поместить на карту нужную сумму денег можно так же, как и Боеприпасы. (см. выше)

Ключи - открывают закрытые двери, окна и контейнеры.
Чтобы привязать ключ к закрытому объекту, впишите номер (например, цифру 7) в поле "Key ID", находящееся в окне редактирования ключа. Затем в таком же поле, но уже в окне редактирования закрытого объекта, впишите тот же номер. Всё! Теперь этот ключ откроет закрытую дверь, сундук и т.п.

Обратите внимание, что два Key ID зарезервированы:

Для ключей.
0 - этот ключ не сможет ничего открыть.
1 - этот ключ сможет открывать все закрытые двери, сундуки и т.д.

Для закрытых объектов (двери, сундуки и т.д.)
0 - никакой ключ не откроет этот объект.
1 - этот объект откроет любой ключ.


Critters

Курсор - это переключатель в режим выбора. Вы можете перемещать и копировать любые объекты (для копирования удерживайте нажатой кнопку Ctrl).
Для удобства эта кнопка продублирована во всех закладках.

Внимание! При перемещении любых существ не забывайте обозначить для них новую дневную и ночную точки. Для этого после перемещения щёлкните правой кнопкой мыши на существе и выберите "Day Stand", а затем также "Night Stand". (см. раздел "NPC").

Если этого не сделать - существо в игре будет находиться не на том месте, куда вы его переместили, а там где вы его создали. Причём это будет заметно только в игре, но не в редакторе!

Удалить - это переключатель в режим удаления. Просто нажмите эту кнопку и затем щёлкните на том, что вы хотите удалить. Для удобства эта кнопка продублирована во всех закладках.
Примечание: чтобы удалять стены - удерживайте при этом нажатой кнопку Ctrl.

Существо - эта кнопка используется для размещения всех людей, монстров и животных в игре. Кнопкой "Select" можно выбрать существо.

Чтобы добавить в инвентарь существа какой-нибудь предмет нужно просто перетащить мышью предмет на существо.

Если вы хотите одеть существо в броню/одежду, то удерживайте при перетаскивании нажатой кнопку Shift.

Чтобы удалить содержимое инвентаря, щёлкните на существе правой кнопкой мыши и выберите "Poop". В результате, весь инвентарь окажется на земле. Вам, возможно, придётся переместить существо, чтобы увидеть предметы под ним.

Генератор

Генератор - это инструмент для респауна любых существ в игре. С помощью генератора, можно организовать восстановление монстров и NPC. Локации, в которых вы уничтожили всех монстров, будут снова заселяться ими через определённое время.

Чтобы запустить генератор, щёлкните правой кнопкой мыши на любом существе и выберите "Edit". В появившемся окне нажмите кнопку "Generator".

Теперь разберёмся что к чему. Чтобы включить генератор, нажмите кнопку "Yes".

"Generator ID" - номер генератора. Используется в скриптах.

"Inactive On-Screen" - отключает генератор, если во время игры он находится на экране.

"Spawn per Beat" - определяет, сколько создавать существ за один такт работы генератора.

"Time Active" - определяет когда будет работать генератор (днём, ночью или круглосуточно).

"Spawn Beat Rate" - это скорость генерации существ.

"Concurrent" - максимальное кол-во одновременно присутствующих существ.

"Total" - определяет максимальное кол-во ВСЕХ создаваемых этим генератором существ.

"Ignore Total" - эта опция заставляет генератор игнорировать "Total" и он будет создавать существ столько, сколько указано в "Concurrent".


Edit

Курсор - это переключатель в режим выбора. Вы можете перемещать и копировать любые объекты (для копирования удерживайте нажатой кнопку Ctrl).
Для удобства эта кнопка продублирована во всех закладках.

Внимание! При перемещении любых существ не забывайте обозначить для них новую дневную и ночную точки. Для этого после перемещения щёлкните правой кнопкой мыши на существе и выберите "Day Stand", а затем также "Night Stand". (см. раздел "NPC").

Если этого не сделать - существо в игре будет находиться не на том месте, куда вы его переместили, а там где вы его создали. Причём это будет заметно только в игре, но не в редакторе!

Удалить - это переключатель в режим удаления. Просто нажмите эту кнопку и затем щёлкните на том, что вы хотите удалить. Для удобства эта кнопка продублирована во всех закладках.
Примечание: чтобы удалять стены - удерживайте при этом нажатой кнопку Ctrl.

Тайл Скрипт - это тайл с привязанным к нему скриптом. Когда игрок или NPC на него наступает - выполняется скрипт. Щелчок правой кнопкой мыши на тайл скрипте открывает простое окошко, где можно указать номер скрипта в поле ID или удалить тайл скрипт.

Примечание: вы можете перетаскивать тайл скрипты мышью.

Точка Перехода - это телепорт. Наступив неё, вы можете переместиться в другое место карты или на другую карту в вашем модуле.

Перед созданием точки перехода, откройте ту карту на которую должен вести телепорт. Щёлкните правой кнопкой мыши на нужном месте и выберите "Remember for jump point".

Теперь вы можете создать любое кол-во точек перехода на любой карте, и каждый раз редактор будет сам вводить сохранённые координаты в появившемся окне. Вам остаётся только нажать "OK" и переход готов!

Примечание. Синий квадрат точки перехода (который вы видите в WorldEd) в игре невидим. Значит, надо отметить переход каким-нибудь плоским объектом пейзажа. Например, знаком магической школы из Туллы или чем-нибудь подобным.

И ещё учтите, что точки перехода работают только в один конец. Чтобы игрок мог вернуться - создайте другой переход обратно.

Тайл Блок - это тайл по которому не могут ходить игрок или любое другое существо.

Существует два типа тайл блоков: сгенерированные и созданные.

Сгенерированные тайл блоки тёмно-красного цвета, создаются автоматически при размещении на карте фасадов, объектов пейзажа или изменении ландшафта. Они не могут быть отредактированы. Пример: если вы рисуете глубокую воду - она покрывается тёмно-красными тайл блоками, показывающими, что игрок не сможет ходить по ней.

Созданные тайл блоки ярко-красного цвета и вы можете их создавать. Повторный щелчок удаляет тайл блок.


Build

Курсор - это переключатель в режим выбора. Вы можете перемещать и копировать любые объекты (для копирования удерживайте нажатой кнопку Ctrl).
Для удобства эта кнопка продублирована во всех закладках.

Внимание! При перемещении любых существ не забывайте обозначить для них новую дневную и ночную точки. Для этого после перемещения щёлкните правой кнопкой мыши на существе и выберите "Day Stand", а затем также "Night Stand". (см. раздел "NPC").

Если этого не сделать - существо в игре будет находиться не на том месте, куда вы его переместили, а там где вы его создали. Причём это будет заметно только в игре, но не в редакторе!

Удалить - это переключатель в режим удаления. Просто нажмите эту кнопку и затем щёлкните на том, что вы хотите удалить. Для удобства эта кнопка продублирована во всех закладках.
Примечание: чтобы удалять стены - удерживайте при этом нажатой кнопку Ctrl.

Здания. В отличии от других объектов на карте, здания создаются ТОЛЬКО в режиме "Top-down". Кнопками "previous" и "next" можно выбирать типы построек от каменного дома до железного забора.

Переключившись в режим "Top-down", вы увидите карту покрытую красными точками. Щёлкните левой кнопкой мыши на точке и, не отпуская кнопку, проведите к соседней точке. Зелёная линия будет отмечать будущую стену. Если вы проведёте по горизонтали или вертикали, на карте появится стена. Если по диагонали - дом. Когда вы отпустите кнопку - они появятся на карте. В уже созданном доме вы можете достраивать стены.

Двери могут быть помещены на стену, причём и на внешние стены, и на внутренние. Каждый тип стен имеет свой набор дверей. Создаются двери просто щелчком левой кнопкой мыши. Последовательно щёлкая на двери, вы можете выбирать вид двери. Вы также можете создать большую дверь, просто щёлкните рядом с существующей дверью и она удвоится.

По умолчанию, все двери одинаковы по своим характеристикам. Они открыты и их можно уничтожить. Редактируются двери как и остальные объекты - щёлкните на них правой кнопкой мыши и выберите "Edit".

Окна могут быть помещены на большинство стен в WorldEd. Окна, в отличие от дверей, имеют различные свойства по умолчанию. Некоторые окна, по умолчанию, не могут быть открыты и некоторые непрозрачны (витражи или забиты досками). Чтобы создать окно, щелкните левой кнопкой мыши на стене. Последовательно щёлкая на окне, вы можете выбирать его вид. Вы также можете создать большое окно - щёлкните рядом с существующим и оно удвоится/утроится.

Чтобы изменить свойства окна, щёлкните на нём правой кнопкой мыши и выберите "Edit".

"P" части - это различные варианты оформления стен. В них входят различные по размеру варианты (например, камин или стена библиотеки). Некоторые виды стен имеют много р-частей, а некоторые не имеют ни одной. Создаются р-части просто щелчком левой кнопкой мыши. Последовательно щёлкая на стену, вы можете выбирать вид р-части.

Уничтожить существо - это, прежде всего, пример странности разработчиков. Этой кнопке место в закладке "Critters" (Существа), а она оказалась здесь. Тем не менее эта кнопка работает и позволяет убить любое существо. Сделано это для тех случаев, когда вам понадобится свежий труп :-). Просто нажмите эту кнопку и щёлкните на существе.

Примечание: вы можете поворачивать труп щелчком правой кнопкой мыши на теле и выбором пункта "Rotate".


Редактор объектов

Вы можете щелкнуть правой кнопкой мыши почти на любом объекте в WorldEd и выбрать пункт "Edit". После этого перед вами появится окно редактирования. Доступные настройки могут различаться в зависимости от типа объекта, но некоторые параметры одинаковы для всех. Если параметр доступен только определённым типам объектов, то об этом указано в описании или под ним в скобках даны типы объектов.

Кнопки
Flags...
Scripts...
Light... 		Conceal
Level...
 Spells... 		Skills...
 Generator...
Blend...

Параметры
AC
Hit Points
 Internal
 Known
 Resistance
 AC Adj
Age
AI Data
Alignment
Ammo Type
Basic Stats
Bonus to Hit
Crit Body Type
Crit Hit Chart
Crit Miss Chart
Damage
Derived Stats
Effects Dscr
End Line
Faction
Gender 		Inventory Source
Key ID
Level Scheme
 Lock Difficulty
Magic AC Adj
Magic CH %
Magic CM %
Magic Hit Adj
Magic MS Adj
Magic Range Adj
Magic SM Adj
Magic Speed Adj
Magic Tech Complexity
Magic Wt Adj
Mana Store
Min Strength
Notify NPC
Origin
Poison Level
Portrait 		Quantity
Race
Range
Reaction Base
Resistance Adj
Respawn Delay
Retail Price Mod
Scale
Silent Move Adj
Social Class
Sound Effect
Speed Factor
Spell
Spell Mana Store
Start Line
Trap Difficulty
Unknown
Wait Tolerance
Weight
Worth
Written Type

Кнопки

Flags...
Флаги. Подробные описания флагов смотрите в следующем разделе данного манулала.

Scripts...
Позволяет привязать к данному объекту скрипт.

Light...
Освещение объекта.

Conceal
Заставит существо использовать навык "Скрытность" (если доступно). Существо автоматически раскроет себя при нападении или перемещении.

Level...
Уровень данного существа.

Spells...
Заклинания, которые знает существо.

Skills...
Уровень навыков данного существа.

Generator...
Генератор существ (см. раздел "Critters").

Blend...
Открывает окно, в котором можно установить уровень прозрачности существа. Чтобы изменить прозрачность, нажмите кнопку "Yes" рядом с написью "Use Constant Alpha Blending?". Прозрачность измеряется от 255 (полностью непрозрачен) до 0 (полностью прозрачен)

Параметры

AC:
Класс Брони (Armor Class) объекта.

Hit Points:
Это поле определяет, сколько повреждений может выдержать объект прежде, чем будет уничтожен.

Internal:
Это внутреннее имя объекта. Используется для идентификации объекта в скриптах и диалогах.

Known:
Это описание объекта. Для существ и магических предметов - это название объекта после того, как вы встретили/идентифицировали объект.

Resistance:
Сопротивления объекта можно устанавливать в диапазоне от 0 до 95:

Damage: сопротивление обычному повреждению.
Electrical: сопротивление электричеству.
Fire: сопротивление огню.
Magic: сопротивление магии.
Poison: сопротивление яду.

AC Adj:
Это число устанавливает насколько увеличится AC (Класс Брони) существа, когда броня будет одета.
(броня)

Age:
Возраст существа. Мало используется в игре, но может быть проверен в скриптах.
(существо)

AI Data:
Это номер исскуственного интеллекта (AI) для этого существа. Вы можете редактировать AI в файле gameai.mes
(существо)

Alignment:
Мировоззрение (Карма/Характер) существа. Помните, что этот параметр записывается здесь не так, как вы видите его в игре, а с умножением на 10.
Т.е. в диапазоне от -1000 (очень злой) до 1000 (очень добрый), 0 = нейтральный.
(существо)

Ammo Type:
Указывает тип боеприпасов, которые будет использовать оружие.
(оружие)

Basic Stats:
Восемь параметров существа:

Beauty - Красота
Charisma - Обаяние
Constitution - Телосложение
Dexterity - Ловкость
Intelligence - Интеллект
Perception - Восприятие
Strength - Сила
Willpower - Сила Воли

Bonus to Hit:
Это бонус (или штраф - если отрицательно) к точности, который получит владелец оружия.
(оружие)

Crit Body Type:
Тип тела определяет возможные критические удары и промахи.
(существо)

Crit Hit Chart:
Определяет возможные типы критических ударов.
(оружие)

Crit Miss Chart:
Определяет возможные типы критических промахов.
(оружие)

Damage:
Нажав на эту кнопку, вы откроете свойства оружия (Weapons). Для каждого типа урона от этого оружия, можно выбрать:

Low: минимальный урон (без модификаторов)
High: максимальный урон (без модификаторов)
Magic: дополнительный урон (число может быть положительным или отрицательным, и зависит от склонности владельца к магии)

Derived Stats:
Вторичные способности существа. Их нельзя изменить, но они зависят от Basic Stats (первичных способностей).

AC Adjustment: (модификатор Класса Брони)
Carry Weight: (максимальный вес)
Damage Bonus: (бонус к атаке)
Heal Rate: (скорость лечения)
Magic Tech Aptitude: (склонность к магии/технологии)
Max Followers: (максимум спутников)
Poison Recovery Rate: (скорость лечения от яда)
Reaction Modifier: (модификатор реакции)
Speed: (скорость)

Effects Dscr:
Это описание предмета, которое вы видите, когда исследуете предмет. Если предмет магический, то он должен быть идентифицирован.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

End Line:
Этот параметр больше не используется.
(письменный)

Faction:
Фракция в которой находится существо. (см. раздел "NPC").
(существо)

Gender:
Пол существа (мужской или женский). Влияет на силу, телосложение, диалоги и т.д.
(существо)

Inventory Source:
Исходный ивентарь. Т.е. список предметов.
(существо, контейнер)

Key ID:
Это идентификатор (ID) ключа. (см. раздел "Items").
(контейнер, ключи, двери и окна)

Level Scheme:
Это схема, которую будет использоваться при повышении уровня существа.
(существо)

Lock Difficulty:
Сложность замка. Положительное число усложнит работу взломщику. Отрицательное, наоборот, поможет взломать замок.
(контейнер, двери и окна)

Magic AC Adj:
Бонус к классу брони (Armor Class). Зависит от склонности владельца к магии/технологии.
(броня)

Magic CH %:
Это число влияет на шанс нанести критический удар и зависит от склонности владельца к магии/технологии.
(оружие)

Magic CM %:
Это число влияет на шанс критического промаха и зависит от склонности владельца к магии/технологии.
(оружие)

Magic Hit Adj:
Модификатор точности, который зависит от склонности владельца к магии/технологии.
(оружие)

Magic MS Adj:
Это число влияет на шанс промаха. Зависит от склонности владельца к магии/технологии.
(оружие)

Magic Range Adj:
Модификатор дальнобойности оружия, который зависит от склонности владельца к магии/технологии.
(оружие)

Magic SM Adj:
Модификатор шумности брони, зависящий от склонности владельца к магии/технологии.
(броня)

Magic Speed Adj:
Модификатор скорости скорости оружия, зависящий от склонности владельца к магии/технологии.
(оружие)

Magic Tech Complexity:
Определяет насколько предмет магический или технологический. Изменяется в диапазоне от -100 (технология) до 100 (магия).
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Magic Wt Adj:
Модификатор веса предмета, зависящий от склонности владельца к магии/технологии. Т.е. при отрицательном числе - предмет станет легче.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Mana Store:
Кол-во энергии в предмете. При использовании любого заклинания, в первую очередь будет использована энергия предмета, а не его владельца. Т.е. этот предмет даст владельцу дополнительные очки, которые можно использовать только для заклинаний. Эти очки медленно восстанавливается со временем.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Min Strength:
Минимальная сила, требуемая, чтобы без штрафа использовать оружие (MSR).
(оружие)

Notify NPC:
Это внутреннее имя (internal) существа, которое будет охранять контейнер, окно или дверь. (см. раздел "NPC")
(контейнер, двери и окна)

Origin:
Здесь вы можете указать происхождение NPC. При одинаковом происхождении, стражники всегда будут защищать NPC, независимо от фракций.
(существо)

Poison Level:
Вы можете сделать изначально отравленное существо, указав здесь уровень яда. Вообще, уровень яда 550 или выше действительно ужасен. Более чем 200 - это серьезное отравление.
(существо)

Portrait:
Номер портрета.
(существо)

Quantity:
Кол-во мелких предметов. Например, золотых монет.
(боеприпасы, монеты)

Race:
Раса существа. Не имеет значения для монстров, животных и нежити.
(существо)

Range:
Дальнобойность оружия.
(оружие)

Reaction Base:
Реакция существа без учёта модификаторов. 50 - нейтрально, 0 - ненависть, 100 - любовь.
(существо)

Resistance Adj:
Характеристики брони. Т.е. насколько изменятся сопротивления существа в этой броне.
(броня)

Respawn Delay:
Промежуток времени, по истечении которого, объект пейзажа будет восстановлен после разрушения (если он отмечен флагом "Respawnable").
 (пейзаж)

Цифра 0 означает один день. Положительное число означает реальные секунды (пауза в игре, остановит отсчёт). Отрицательное число означает секунды в игре. (Помните, что 1 реальная секунда = 8 секунд в игре).

Retail Price Mod:
Модификатор базовых цен на товары (в процентах; 100% = базовая цена). Т.е. этот параметр указывает, сколько будет "наваривать" данный торговец на продаже всех своих товаров. Базовая цена каждого предмета указывается параметром Worth (см. далее).
(существо)

Scale:
Размер существа. Указывается в процентах (100% = исходный размер).
(существо)

Silent Move Adj:
Влияние брони на способность её владельца тихо ходить. Т.е. этот параметр влияет на уровень "Скрытности", но только при передвижении.
(броня)

Social Class:
Социальный класс существа. В основном, этот параметр влияет только на сгенерированные фразы в диалогах.
(существо)

Sound Effect:
Вы можете выбрать звуковой эффект для элемента пейзажа. Звук будет слышен, когда игрок близко к объекту (см. описание флага "Positional Audio" в разделе "Флаги").
(пейзаж)

Speed Factor:
Скорость оружия. Помните, что звание ученика в соответствующем навыке, увеличит этот параметр на 5.
(оружие)

Spell 1: | Spell 2: | Spell 3: | Spell 4: | Spell 5:
Заложеные в предмет заклинания. Они не потребляют энергию владельца, и кол-во использований зависит от параметра Spell Mana Store.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Spell Mana Store:
Это число определяет, сколько раз можно использовать заложеные в предмет заклинания. Если указать здесь отрицательное число, то их можно будет использовать бесконечно.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Start Line:
Используется в записках, книгах и т.д. Определяет какой текст в файле mes будет отображаться.
(письменный)

Trap Difficulty:
Сложность ловушки. Чем больше это число - тем труднее обезвредить ловушку. Чем меньше - тем легче.
(ловушка)

Unknown:
Описания неизвестных объектов используются для существ, с которыми игрок ещё не разговаривал. И для магических предметов, пока они не идентифицированы.
(существо, общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Wait Tolerance:
Этот параметр определяет время, в течении которого NPC будет ждать игрока (если игрок сказал NPC подождать).
(существо)

Weight:
Вес предмета.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Worth:
Базовая цена предмета без учёта модификаторов. Реальная цена вычисляется на основе базовой цены, уровня навыка "Торговля" у игрока, модификатора "Retail Price Mod" у торговца и его реакции.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Written Type:
Тип письменного предмета. Этот параметр влияет на внешний вид в игре и выбор файла mes, в котором будет записан текст.
(письменный)


Флаги

Aloof
Always Locked
Animal
Boomerangs
Busted
Can Use Box
Fence
 Flat
Hand Count Fixed
Hexed
Identified
 Illusion
 Invulnerable
Is Fire
Is Magical
Jammed
 Kill on Sight
Locked
Locked Day
Locked Night 		Loud
 Magically Held
Marks Townmap
Mechanical
Mute
Needs Target
Never Locked
Nigh Invulnerable
No Auto Animate
No Blood Splotches
No Decay
 No Disintegrate
No Display
No Drop
No Flee
No NPC Pickup
No Pickpocket
Nocturnal
Non-Lethal Combat
Off 		Only Cast Highest
Persistent
Positional Audio
Respawnable
Silent
Sticky
Stolen
Throwable
Torch/shield loc
Transfer Light
Two Handed
Uber
Undead
Unressurectable
Unrevivable
Wanders
Wanders in Dark
Waypoints Day
Waypoints Night
Won't Sell

Часто используемые флаги

Флаги - это метки, которые вы можете присваивать существам, предметам, элементам пейзажа и т.д. Флаги добавят им различные функции и свойства. После описания каждого флага в скобках указано для каких объектов он предназначен.

Aloof
 Реакция существа не будет зависеть от расы и и красоты игрока.
 (существо)

Always Locked
Объект будет закрыт абсолютно для всех в игре. Действует только при установленном флаге "Locked".
(контейнеры, двери и окна)

Animal
 Это существо считается животным. Это важно для заклинаний. Кроме того, животные не могут открывать двери, их реакция не зависит от расы и красоты игрока, они не могут торговать.
(существо)

Boomerangs
Это оружие возвратится при броске назад.
(оружие)

Busted
Объект открыт, а его замок уничтожен.
(контейнеры, двери и окна)

Can Use Box
Этот предмет можно использовать.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Fence
Это существо будет покупать краденые предметы (отмеченные флагом "Stolen").
(существо)

Flat
Объект пейзажа становится плоским. Т.е. по нему можно ходить и на него можно поместить другие объекты.
(пейзаж)

Hand Count Fixed
Если оружие отмечено флагом "Two Handed", то этот флаг позволит использовать это оружие ТОЛЬКО двумя руками. Если этот флаг не установлен, то оружие можно держать и в одной руке.
(оружие)

Hexed
Этот предмет проклят и его название будет оранжевого цвета.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Identified
Отмечает магический предмет как опознанный. Это позволит использовать его магические эффекты и видеть его название.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Illusion
НЕ РАБОТАЕТ.

Invulnerable
Абсолютно неуязвимый объект/существо. Никакое оружие или заклинание не может причинить ему урон (даже Дезинтеграция). Неуязвимое существо не может подбирать предметы и атаковать.

Is Fire
Это огненный объект. Он наносит огненный урон всем находящимся рядом с ним.
(пейзаж)

Is Magical
Магический предмет.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Jammed
Замок сломан и его невозможно вскрыть отмычками.
(контейнеры, двери и окна)

Kill on Sight
Существо будет атаковать любое другое существо, которое не входит в его фракцию.
(существо)

Locked
Объект будет закрыт, но только для игрока (исключение: игрок может открыть дверь или окно изнутри дома). А вот NPC могут совершенно свободно проходить через закрытые этим флагом двери и окна. Помните, что это главный флаг закрытия объекта - без него не будут работать флаги "Locked Day", "Locked Night" и "Always Locked".
(контейнеры, двери и окна)

Locked Day
Объект будет закрыт только днём. Действует только при установленном флаге "Locked".
(контейнеры, двери и окна)

Locked Night
 Объект будет закрыт только ночью. Действует только при установленном флаге "Locked".
(контейнеры, двери и окна)

Loud
Это оружие производит много шума и его можно услышать на расстоянии до 15 тайлов.
(оружие)

Magically Held
Этот объект магически заблокирован.
(контейнеры, двери и окна)

Marks Townmap
Исследование этого объекта пейзажа добавит метку на карту города.
(пейзаж)

Mechanical
Это механическое существо. Получает иммунитет к яду, его реакция не зависит от расы и красоты игрока, не разговаривает.
(существо)

Mute
Это существо не может говорить.
(существо)

Needs Target
Для использования этого предмета нужна цель.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Never Locked
Отменяет флаг "Locked". Объект не будет заперт.
(контейнеры, двери и окна)

Nigh Invulnerable
Почти неуязвимое существо. Это "почти" означает, что нанести ему урон можно только особым оружием, отмеченным флагом "Uber". Если не отметить такое существо флагом "No Disintegrate", то произойдёт баг с Дезинтеграцией - существо не погибнет, а просто исчезнет. При этом заклинатель вообще не получит опыта. Неуязвимое существо не может подбирать предметы и атаковать.
(существо)

No Auto Animate
Отключает анимацию элемента пейзажа. Если этот флаг не установлен, то анимация отображается автоматически.
(пейзаж)

No Blood Splotches
НЕ РАБОТАЕТ.

No Decay
Этот предмет не будет исчезать, если он долго лежит на земле.
(существо, общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

No Disintegrate
У этого существа есть полный иммунитет к Дезинтеграции.
(существо)

No Display
Этот предмет не отображается в инвентаре.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

No Drop
Этот предмет нельзя выбросить.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

No Flee
Это существо никогда не сбежит во время боя.
(существо)

No NPC Pickup
NPC никогда не подберут этот предмет, если он лежит на земле.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты)

No Pickpocket
Это существо нельзя обокрасть.
(существо)

Nocturnal
Объект и его освещение будут видны только ночью.
(пейзаж)

Non-Lethal Combat
Это существо прекратит атаку, если его противник потерял сознание.
(существо)

Off
Отключает объект. Он полностью исчезает из игры и может появиться только если его включить через скрипт.

Only Cast Highest
Если это существо владеет магией, то в каждой известной ему в каждой школе заклинаний будет использовать только заклинания самого высокого уровня.
(существо)

Persistent
Этот предмет не уничтожается при перезагрузке инвентаря.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Positional Audio
Определяет радиус, в котором будет слышен звуковой эффект данного объекта пейзажа. Small - 2 тайла, Medium - 5 тайлов, Large - 10 тайлов, Extra Large - 20 тайлов.
(пейзаж)

Respawnable
В случае уничтожения, объект будет восстановлен после задержки, указанной в "Respawn Delay".
(пейзаж)

Silent
Это оружие почти бесшумно и его можно услышать только на расстоянии 2 тайлов.
(оружие)

Sticky
Этот объект не будет автоматически закрываться после открытия.
(контейнеры, двери и окна)

Stolen
Этот предмет был украден, и купит его только существо отмеченное флагом "Fence".
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Throwable
Это оружие можно бросить в цель. При этом оно нанесёт те же повреждения, что и в ближнем бою. Если этот флаг не установлен, то при броске урон будет зависеть от веса предмета.
(оружие)

Torch/shield loc
Этот предмет можно поместить в слот щита.
(общие предметы)

Transfer Light
НЕ ИСПОЛЬЗУЕТСЯ.

Two Handed
Это двуручное оружие. Если его держат одной рукой (т.е. в другой руке щит и т.п.), то минимальная требуемая сила (MSR) больше 4.
(оружие)

Uber
Этот предмет может нанести урон даже неуязвимым существам, которые отмечены флагом "Nigh Invulnerable".
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Undead
Это существо - нежить. Имеет иммунитет к яду и не может потерять сознание. Его нельзя ослепить или напугать. Реакция нежити не зависит от расы и красоты игрока.
(существо)

Unressurectable
Если это существо умрёт, то его нельзя воскресить, но можно превратить в зомби.
(существо)

Unrevivable
Это существо невозможно оживить или превратить в зомби.
(существо)

Wanders
Это существо будет блуждать на расстоянии до 4 тайлов от точки своего расположения.
(существо)

Wanders in Dark
Это существо будет блуждать в темноте.
(существо)

Waypoints Day
Существо будет двигаться по своим точкам пути(waypoints) только днём. Ночью оно пойдёт к своей ночной точке (night stand).
(существо)

Waypoints Night
Существо будет двигаться по своим точкам пути(waypoints) только ночью. Днём оно пойдёт к своей дневной точке (day stand).
(существо)

Won't Sell
NPC продаст этот предмет только мастеру Торговли.
(общие предметы, оружие, броня, письменный, боеприпасы, монеты, ключи)

Часто используемые флаги

Пейзаж

Click Through - если этот флаг НЕ установлен, то при наведении курсора объект будет подсвечиваться и вы увидите его название.

Nocturnal - если этот флаг установлен, объект и его освещение будут видны только ночью.

Is Fire - сделает этот объект огненным. Т.е. все близко подошедшие получат повреждения огнём.

Контейнеры, двери и окна

Locked
Объект будет закрыт, но только для игрока (исключение: игрок может открыть дверь или окно изнутри дома). А вот NPC могут совершенно свободно проходить через закрытые этим флагом двери и окна. Помните, что это главный флаг закрытия объекта - без него не будут работать флаги "Locked Day", "Locked Night" и "Always Locked".

Never Locked - этот флаг отменяет предыдущий флаг.

Locked Day
Объект будет закрыт только днём. Действует только при установленном флаге "Locked".

Locked Night
 Объект будет закрыт только ночью. Действует только при установленном флаге "Locked".

Существа

No Flee - это существо никогда не сбежит во время боя.

Waypoints Day - существо будет двигаться по своим точкам пути(waypoints) только днём. Ночью оно пойдёт к своей ночной точке (night stand).

Waypoints Night - существо будет двигаться по своим точкам пути(waypoints) только ночью. Днём оно пойдёт к своей дневной точке (day stand).

Kill on Sight - существо будет атаковать всех, кто не входит в его фракцию.

Wanders - это существо будет блуждать на расстоянии до 4 тайлов от точки своего расположения.

Оружие и другие предметы

Identified - Опознанный предмет. Если флаг установлен для магического предмета, то он считается опознанным. Отображается его название и используются магические эффекты.

No Decay - этот предмет не будет исчезать, если он долго лежит на земле. Если этот флаг не установлен, то предмет исчезнет через два дня.

No NPC Pickup - NPC никогда не подберут этот предмет, если он лежит на земле.


Карты

Содержание:

  • Секторы

  • Карта Мира

  • Привязка карт к Карте Мира

  • Городские карты (TownMaps)

  • Схемы Освещения

Секторы

Карта в Аркануме состоит из секторов. Секторы - это фрагменты карты, которые могут иметь уникальные свойства: привязанный скрипт, городскую карту, свою музыку, свои фоновые звуки, своё освещение и т.д. Удобнее всего работать с секторами в режиме "Top-down". Тогда границы секторов будут отображаться жёлтыми линиями.

Щёлкнув правой кнопкой на секторе, вы откроете такое меню:

Fill with tile type... - покрывает весь сектор одним типом поверхности.

Script... - привязывает к данному сектору скрипт.

Town Map... - выбор городской карты (см. далее).

Light Scheme... - схема освещения сектора (см. далее). По умолчанию, доступны две:

  • Lighting Default - стандартная смена дня и ночи.
  • Lighting Dungeon - подземелье. Темно и нет смены дня и ночи.

Sound Schemes... - выбор музыки (Music) и фонового звука (Ambient) для данного сектора.

Magic/tech apptidude... - позволяет устанавливать бонус к магии или технологии, который получат все в данном секторе. Например, бонус к технологии на вокзале Таранта сделан именно таким способом.

Block on world map - запретить передвижение через этот сектор по карте мира. Т.е. игрок не сможет пройти через сектор, используя карту мира. Можно будет пройти только в обычном режиме.

Delete... - удаляет ВСЁ содержимое сектора и покрывает его базовым типом поверхности.

Карта Мира

Локации на Карте мира прописываются в файле gamearea.mes в папке mes. Не трогая оригинальные локации, можно добавлять свои.

Пример:

{82}{77880, 72900, 0, 0 /Новый Тарант/описание локации}

В начале строки указывается номер локации.

Жёлтым цветом выделены координаты точки, где вы появитесь, если зайдете и телепортируетесь в эту область (например, приходя в Тарант, вы появляетесь возле моста. Координаты этой точки и прописаны для локации Тарант). Координаты указываются в тайлах!

Зелёным цветом отмечены названия локаций, после них через знак "/" идёт описание, которое возникает при наведении курсора.

Ещё есть необязательный параметр Radius: радиус локации (в секторах!). Т.е. расстояние на котором эту локацию можно обнаружить при движении по карте мира. По умолчанию (если его не указывать), радиус локации равен 5 секторам. Если вы хотите, чтобы локация вообще не появлялась на Карте Мира когда игрок пройдёт рядом с ней, то установите отрицательный радиус локации. Это позволит создать секретную локацию.

Пример:

{82}{77880, 72900, 0, 0 /Секретная зона/описание/Radius: -1}

Эта локация может появиться на Карте Мира только при помощи скрипта или диалога. Полезно, если надо создать секретную локацию.

Привязка карт к Карте Мира

Представим, что в городе есть подземелье (или что-то другое), которое на самом деле находится на другой карте. Как же сделать, чтобы всё выглядело как будто вы находитесь в городе? Сделать так, чтобы в подземелье работала телепортация и свиток выхода?

Для этого нужен номер локации, к которой будет привязано подземелье. Эта локация обязательно должна быть на главной карте Арканума. Откройте уже знакомый вам файл gamearea.mes в папке mes и запомните номер нужной локации (например, номер 21 - это Тарант).

Теперь открываем файл MapList.mes в папке Rules и добавляем к строке карты подземелья параметр "Area: X". Где X - это номер локации из файла gamearea.mes

Пример:

{5081}{New_Dungeon, 96, 126, WorldMap: 0, Area: 21}

Городские карты (TownMaps)

Городские карты - это миникарты локаций в игре. Они обеспечивают изометрический обзор на локацию как бы с большой высоты. Если отметить секторы карты как часть какой-либо городской карты, то редактор может их автоматически сгенерировать.

Городские карты прописываются в файле TownMap.mes , который находится в папке rules. Строка выглядит просто:

{1}{my town}

Номер строки и название городской карты (в данном случае - my town), которое потом надо будет выбрать в WorldEd для генерации. ВНИМАНИЕ! Строка "0" всегда ДОЛЖНА быть пустой!

По умолчанию, игрок не может "ждать" на секторе с городской картой и она изначально неисследована. Чтобы этого не было, нужно отметить городскую карту флагом " [w:1]. Пример:

{1}{my town [w:1]}

Теперь игроку будет иметь доступ в меню ожидания и карта будет изначально полностью исследована.

После редактирования файла TownMap.mes, запускаем WorldEd (если он был запущен на момент редактирования - перезагрузите модуль). Переключитесь в режим Top-down, чтобы видеть границы секторов (жёлтые линии). Щёлкните правой кнопкой мыши на нужном секторе и выберете "Town Map". В появившемся окне выберите в выпадающем списке название карты. Затем обязательно переключитесь в режим Isometric и выберете в главном меню редактора Tools -> Generate Town Maps. Редактор задаст вам несколько вопросов - ответьте на все "Да". Теперь подождите пока будут сгенерированы городские карты для тех секторов, которым вы их определили.

Схемы Освещения

Схемы Освещения предназначены для равномерного освещения целого сектора или всей карты. В отличии от источников света, схемы освещения могут изменяться в зависимости от времени суток (смена дня и ночи в Аркануме именно так и реализована) и не вызывают тормозов в игре.

В каждой схеме освещения отдельно прописывается два типа освещения:

Внешнее (Outdoor) - это освещение под открытым небом.
Внутреннее (Indoor) - только внутри зданий и в подземельях.

Каждая схема освещения это текстовый файл с расширением mes (название_схемы.mes) в папке Rules данного модуля. Стандартная схема освещения выглядит так:

{0}{74, 80, 98, 74, 80, 98} 12AM
{1}{} 1AM
{2}{} 2AM
{3}{} 3AM
{4}{74, 80, 98, 74, 80, 98} 4AM
{5}{} 5AM
{6}{213, 182, 222, 74, 80, 98} 6AM
{7}{} 7AM
{8}{} 8AM
{9}{255, 255, 246, 74, 80, 98} 9AM
{10}{} 10AM
{11}{} 11AM
{12}{255, 255, 255, 74, 80, 98} 12PM
{13}{} 1PM
{14}{} 2PM
{15}{255, 255, 246, 74, 80, 98} 3PM
{16}{} 4PM
{17}{} 5PM
{18}{246, 186, 148, 74, 80, 98} 6PM
{19}{} 7PM
{20}{74, 80, 98, 74, 80, 98} 8PM
{21}{} 9PM
{22}{} 10PM
{23}{74, 80, 98, 74, 80, 98} 11PM

Номер каждой строки соответствует времени суток: 0 - полночь, 1 - час ночи, 2 - два часа ночи и т.д. Освещение записывается в обычном RGB диапазоне 0-255 (красный/зелёный/синий) через запятую. Первые три значения - Внешнее Освещение, далее - Внутреннее.

Никогда не удаляйте номера строк и фигурные скобки! Оставляйте их пустыми, если они не нужны. В этом случае игра будет использовать предыдущую не пустую строку. Т.е. строки заполняют только когда нужно сменить освещение. Каждая схема освещения обязательно должна быть прописана в файле Lighting Schemes.mes в папке Rules данного модуля.

Вы можете присвоить схему освещения как отдельному сектору, так и всей карте. В первом случае просто щёлкните правой кнопкой мыши пустое место на карте, выберите "Light Scheme" и найдите в выпадающем списке нужную схему.

Чтобы присвоить схему освещения всей карте нужно в её папке открыть файл mapinfo.txt и изменить параметр LightScheme:X. Где X - номер схемы из Lighting Schemes.mes


NPC

Содержание:

  • Имена

  • Передвижение

  • Охрана

  • Фракции (Factions)

  • Происхождение (Origin)

NPC - это все живые существа в игре, которые не управляются игроком: монстры, животные, жители городов, спутники главного героя и т.д.

Имена

(<папка модуля>\mes\gamedesc.mes)

Файл gamedesc.mes используется для хранения имён NPC и названий всех объектов в игре.
Пример строки:

{30001}{Геральт}

Зелёным отмечен порядковый номер строки, который должен быть от 30000 и выше.
Жёлтым отмечено имя/название объекта так, как оно будет видно в игре.

Теперь запускаем WorldEd, щёлкаем правой кнопкой мыши на NPC и выбираем "Edit". В появившемся окне есть два выпадающих списка: "Unknown" и "Known".

"Unknown" - это имя NPC до первого разговора с ним.
"Known" - это имя уже известного вам NPC (т.е. после первого разговора).

Передвижение

Патруль

Щёлкаем на NPC правой кнопкой мыши и выбираем пункт "Waypoints". Теперь левой кнопкой указываем точки пути по которым будет двигаться NPC.

Чтобы отменить точки пути, щёлкните на NPC правой кнопкой мыши и снова выберите пункт "Waypoints".

Чтобы сохранить точки пути, щёлкните NPC правой кнопкой мыши и уберите галочку с пункта "Show Waypoints".

Дневная и Ночная точка

Это точки, где NPC будет находится в разное время суток. Днём он будет стоять на дневной точке, а когда наступит ночь, пойдёт на ночную точку. И наоборот, когда наступит день, NPC вернётся на дневную точку.

Чтобы отметить эти точки, перетащите NPC на то место, где он должен стоять ночью. Чтобы NPC спал на кровати, поместите его прямо на тайл блок кровати. Щёлкните на нём правой кнопкой мыши и выберите "Night Stand".

Теперь перетащите NPC туда, где он должен быть днём. Щёлкните на нём правой кнопкой мыши и выберите "Day Stand".

Охрана

NPC может охранять контейнер, дверь или окно. Для этого щёлкните правой кнопкой мыши на NPC, и выберите "Remember for Notify". Затем щёлкните на объекте и выберите "Set Notify NPC".

Если игрок попытается взломать охраняемый объект - охранник нападёт на него. Но помните, что NPC должен быть достаточно близко от охраняемого объекта.

Фракции (Factions)

(для модуля Arcanum: \oemes\faction.mes)
(для всех остальных модулей: <папка модуля>\oemes\gamefaction.mes)

Фракции - это группы существ. Объединяя существ в одну фракцию, вы делаете их союзниками, которые будут помогать друг другу в бою.

Фракции делятся на основные и дополнительные. Основные фракции созданы для модуля Arcanum, но их можно использовать в любых ддругих модулях. Дополнительные фракции можно создать отдельно для любого другого модуля.

При создании фракций следует помнить о диапазоне номеров. Диапазон основных фракций: 0-149. Диапазон дополнительных фракций: от 150.

Чтобы включить существо в фракцию щёлкните на нём правой кнопкой мыши и выберите пункт "Edit". В окне редактирования в выпадающем списке "Faction" выберите нужную фракцию.

Происхождение (Origin)

(<папка модуля>\mes\gamearea.mes)

Происхождение - это тоже группа существ, но более крупная и основанная на привязке NPC к определённой локации. Обычно это все жители города. При этом в эту группу могут входить представители разных фракций.


Диалоги

Содержание:

  • Файл диалога

  • Структура диалога

  • Редактор строки

  • Дополнительные возможности

  • Возможные проблемы

Диалоги в Аркануме состоят из двух файлов: скрипт и файл диалога. О файле диалога мы поговорим чуть позже, а пока рассмотрим стандартный скрипт диалога, который присоединяется к NPC и просто запускает диалог при щелчке на NPC. Этот скрипт универсален, т.е. его достаточно создать только один раз, а потом просто копировать его для разных NPC.

Итак, запускаем ScriptMaker и выбираем в меню Line -> Action.

В выпадающем списке выбираем dialog (num) и в появившемся окне в поле Input an integer набираем цифру 1.

Теперь снова выбираем Line -> Action и в выпадающем списке - return and SKIP default

В результате скрипт будет выглядеть так:

0. dialog 1

1. return and SKIP default

Сохраните скрипт под именем 00001name.scr

Где 00001 - это номер скрипта (обязательно пять цифр), а name - любое название (латинскими буквами). Поместите полученный скрипт в папку scr , находящуюся в вашем модуле.

Теперь осталось прицепить скрипт к NPC. Запускаем WorldEd, щёлкаем правой кнопкой мыши на NPC и выбираем пункт "Edit". В окне редактирования нажимаем кнопку "Scripts...".

В появившемся окне отмечаем пункт "Dialog". В поле "Script" вводим номер скрипта (в данном случае 1) и жмём OK. Сохраняем карту и закрываем WorldEd. Дело сделано, переходим к файлу диалога.

Файл диалога

Прежде всего, важное правило. Файл диалога должен иметь одинаковое со скриптом имя. Их различие только в расширении (диалоги арканума - *.dlg ; скрипты - *.scr) и папках, где будут лежать файлы. Для диалогов нужно создать в модуле отдельную папку dlg, в которой они будут находится. Только в этом случае диалог будет работать.

Вы можете набирать диалоги и в Блокноте, а можете воспользоваться специальным редактором. Разумеется, второй вариант значительно проще. Именно его я и опишу в данном мануале.

Диалоги мы будем делать в DiAreA. Для создания даже очень сложных диалогов понадобится минимум знаний, ведь львиную долю работы возьмёт на себя редактор. Вам остаётся набирать текст и указывать в меню нужные действия. Вы можете реализовать тренировки, передачу предметов/денег и многие другие функции без всяких скриптов.

Подробное описание на русском языке каждой строки диалога позволит быстро войти в курс дела, а перенумерация строк с автоматической коррекцией переходов позволит легко редактировать уже существующие диалоги, добавляя в них новые строки.

Окно редактора разделено на две части: в верхней части находятся строки диалога, а в нижней - описание выбранной в данный момент строки. В правом нижнем углу окна под надписью "Варианты перехода" указывается номер строки, на которую делается переход. Двойным щелчком вы можете мгновенно к ней перейти.

Кнопки под главным меню программы позволяют создавать/вставлять/удалять строку диалога, копировать варианты строки (мужской в женский и наоборот), и перемещать строку текста.

Двойным щелчком вы можете отредактировать любую строку диалога в двух режимах: вручную и в "Редакторе строки" (подробно об этом см. далее). Переключатся между ними можно клавишей F4.

Структура диалога

Каждая строка диалога может принадлежать либо NPC, либо игроку. Весь диалог состоит из блоков. Блок - это одна строка NPC и несколько строк игрока (варианты ответа). Переход на другую строку диалога всегда делается со строки Игрока на строку NPC. Кол-во строк игрока неограничено, но одновременно могут отображаться только 5 строк. Следующая строка NPC означает следующий блок.

Большое кол-во строк игрока используется для ветвления диалога в зависимости от параметров игрока. Причём это может быть как разный текст (например, для тупых и для нормальных), так и одинаковый. Думаю, вы не раз встречали в Аркануме случаи, когда одна и та же сказанная игроком фраза приводила порой к совершенно разным результатам, зависящим от расы, пола, обаяния и других параметров главного героя. Делается это всё просто. Создаётся подряд несколько строк игрока с одинаковым текстом, а затем для каждой указывается такое условие для её появления, чтобы игроку была доступна только одна копия.

Например, создаётся две строки с одинаковым текстом. Одна из них появится в диалоге только если игрок - эльф, а другая только если он НЕ эльф. Эти строки будут делать переход на разные строки диалога. В результате в игре происходит проверка главного героя и, в зависимости от его параметров, будет разный результат от одной и той же фразы.

Редактор строки

Редактор строки - это самое главное преимущество DiAreA. Он достаточно прост и понятен, поэтому я не буду разжёвывать мелкие детали, а сосредоточусь на главном. Во всём остальном вы сможете разобраться сами.

1 - выбираем чья это будет строка: Игрока или NPC.

2 - эта неприметная надпись "Диалог" на самом деле скрытая кнопка. Нажав её, вы откроете выпадающий список стандартных возможностей диалога: Приветствие, Торговля, Тренировка и т.д. (см. скриншот ниже)

3 - секция с текстом. Если это фраза Игрока, то указывается какого пола он должен быть и с каким интеллектом, чтобы эта фраза была доступна.
Если это фраза NPC, то в этой секции появляются две строки с текстом (Первый вариант если Игрок мужчина, и второй если женщина).

Далее следуют две секции: "Тесты" и "Результаты". Ряд значков в каждой секции открывают выпадающие меню, в которых можно выбрать нужные условия для появления данного ответа в диалоге и результаты от произнесённых слов. Созданные условия/результаты можно выделить и отредактировать справа под надписью "Параметры". Для принятия введённых параметров нажмите Enter

Под секцией "Результаты" находится "Строка ответа". Это переход в скрипт или на другой блок (определённую строку) этого диалога.

Рядом со строкой ответа находятся пять кнопок:

- сохранить данную строку диалога и открыть предыдущую.

- отменить все изменения в данной строке.

- сохранить данную строку

- сохранить данную строку диалога и открыть следующую.

- сохранить данную строку и закрыть "Редактор строки"

Дополнительные возможности

Если вы хотите чтобы NPC, обращаясь к Игроку, называл его по имени - используйте слово @pcname@. Во время игры это слово будет автоматически меняться на имя Игрока.

Одна из самых полезных функций редактора - это перенумерация строк (Дополнительно -> Перенумерация строк). При этом все переходы в диалоге корректируются автоматически. Так что можно легко вставлять в уже существующие диалоги новые строки. Написание диалогов становится простым делом.

Также достаточно полезна функция, отмечающая границы блоков (Дополнительно -> Добавить пустую строку после каждого блока).

Возможные проблемы

Конечно, при работе с редактором могут возникнуть сложности. Редактор не идеален - в нём тоже есть мелкие баги и недоработки.

Во-первых, не забывайте заполнять в строке NPC оба варианта ответа (для мужчин и для женщин). Сам редактор это не сделает, и вас не предупредит.

Во вторых, иногда случается такой глюк: вы открываете строку NPC с текстом и видите пустое окно "Редактора строки". Нажмите кнопку отмены, и текст появится. Если вы нажмёте другую кнопку - весь текст будет удалён!

В третьих, заведите привычку перед редактированием уже существующего диалога смотреть скрипт, который его запускает. Если в нём нет ссылок на определённые строки диалога (например, dialog 5), то можете редактировать. Если же ссылки есть, то перенумерация строк может полностью разрушить связь между скриптом и файлом диалога!


Торговля

Торговцем может быть любой NPC, как правило он владеет каким-нибудь контейнером (сундук, ящик, бочка и т.д.), в котором находится товар. Также в диалоге с ним должна быть прописана возможность торговать.

Прицепляем контейнер к торговцу

Щелкните правой кнопкой мыши на контейнере и выберите "Remember for Substitute". После этого, правый щелчок на торговце и выберите "Set Substitute Inventory". Контейнер должен быть довольно близко к NPC, иначе NPC просто его не обнаружит.

Примечание. Не забудьте закрыть контейнер (см. раздел "Флаги") и сделать так, чтобы торговец его охранял (см. раздел "Оживляем мир")

В Аркануме существуют много видов торговцев: кузнецы, маги и т.д. Чтобы определить, чем будет торговать созданный торговец - щёлкните правой кнопкой мыши на присоединённом к нему контейнере и выберите "Edit". В появившемся окне, в выпадающем списке "inventory", выберите исходный инвентарь:

General Store Rural - Сельский магазин.
General Store City - Городской магазин.

Gnomish Merchant - Гном Торговец.
Elven Trader - Эльф Торговец.
Herbalist - Торговец травами.
Junk Dealer - Торговец Рухлядью.
Inventor - Изобретатель.
Gupsy - Мудрая женщина.

Smith(Rural) - Сельский Кузнец.
Smith(Quality) - Качественный Кузнец.
Smith(Magical) - Волшебный Кузнец.
Smith(Dwarven) - Дварф Кузнец.
Gun Smith - Продавец огнестрельного оружия.

Magic(General) - Магический магазин
Magic(Light) - - Магический магазин (Белая магия)
Magic(Dark) - Магический магазин (Чёрная магия)
Black Market - Чёрный рынок
Tailor(City) - Городской Портной.
Tailor(Rural) - Сельский Портной.

Также можно настроить уровень цен на продаваемые товары. Щёлкните правой кнопкой мыши на торговце и выберите "Edit". Уровень цен (в процентах) указан в "Retail Price Mod".

Прописываем в диалоге торговлю

Откройте диалог в DiAreA. Откройте в "Редакторе строки" строку Игрока. В появившемся окне, щёлкните надпись "Диалог" (отмечена красной стрелкой на скриншоте). Рядом появится выпадающий список, в нём выберите "Торговля/Игра". Сохраните строку и файл диалога.


Переход между локациями

Переходы между локациями (например, переход с поверхности в какую-нибудь пещеру) реализуются простейшим скриптом телепорта.

Пример скрипта:

0. teleport Triggerer to map 5002 at X:1000 Y:2000

1. return and SKIP default

Пошаговая инструкция

Выбираем действие:

teleport (obj) to map (num) at X:(num) Y:(num).

Вводим переменные:

  1. Оставляем как есть - Triggerer

  2. Вводим номер карты, на которую будет перемещаться игрок (например, 5002). Номера карт записываются в файле MapList.mes, который находится в каталоге rules вашего модуля. Если нужной карты там нет, то значит вы просто её туда не прописали. (см. раздел "Intro").

  3. Указываем координату X для точки, на которую будет перемещаться игрок (например, 1000). Чтобы узнать координаты - наведите курсор на нужную точку и вы увидите их над миникартой. (см. раздел "Интерфейс").

  4. Указываем координату Y (например, 2000).

Выбираем действие:

return and SKIP default

Вот и всё. Скрипт готов. Поместите его в папку scr и только после этого запускайте WorldEd. Теперь щёлкните правой кнопкой мыши на объекте и выберите "Edit". В появившемся окне щёлкните кнопку "Flags" и уберите (если она есть) галочку с пункта "Click through" (см. ниже). Если этого не сделать - скрипт не будет работать.

Теперь цепляйте скрипт к объекту в точку "Use" и введите в поле "Script" номер скрипта (см. ниже).

Телепорт готов.